HAL9000

HAL9000
"It just isn't conceivable that you can design a program strong enough to beat players like me."

July 12, 2016

Android UCI engine update: Texel 1.06

Finally... following a lot of alphas. Thanks to Peter Österlund.

The Texel app released on Google Play version is downloadable HERE. It comes with various versions of which i'm sharing the important ones. They require Android 4.1+.

GET Texel 1.06 for arm7 32-bit
GET Texel 1.06 for arm8 64-bit
GET Texel 1.06 for x86 32-bit
GET Texel 1.06 for x86 64-bit

There are also two prior versions released via Peter's repository, longer in filesize. I guess they contain exactly the same code packed with less compression. I've seen no difference between these and the ones released with the GP app. You may keep them somewhere but you'd better refer to the official release.

GET Texel 1.06 for arm7 32-bit (probably first compile)
GET Texel 1.06 for arm8 64-bit (probably first compile)

P.S.: As seen in a comment below, the so-called first compile for 32-bit works also on devices prior to 4.1. Good to hear that.

2 comments:

Anonymous said...

Hi Gurcan,

Maybe you should add a link to 'HERE' regarding the GP version ( such as https://play.google.com/store/apps/details?id=org.petero.texelchessengine ).

I could not install from GP on my device (ARM Cortex A8 with And 4.0.4) nor run the Texel 1.06 for arm7 32-bit from your repository; I noticed GP requirement for And 4.1+. But Peter's 'unofficial' 32bit larger file runs fine on my device; this makes a difference for some users. Thanks for your great blog and engines repository!

Tibono

Котельников Валерий said...

Precisely, GP the version for Android 4.1+, and the big file is launched even on Android 2.3.6. For example the Stockfish_20160612 version requires 4.1+, also and Komodo 9.X too. Me as owner of the device with Android 4.0.4, it grieves too :(